ggFTW

ggFTW (http://ggftw.com/forum/)
-   Technical Issues (http://ggftw.com/forum/technical-issues/)
-   -   Fixing an external hard drive (http://ggftw.com/forum/technical-issues/79164-fixing-external-hard-drive.html)

Light 07-16-2010 07:50 PM

Fixing an external hard drive
 
Plagued with another unusual and complicated issue.

---

Last month, my external drive was lagging the system when accessed; so I decided to remove it and place it in a safe spot where it wouldn't be touched.

I recently needed a file from it, and thus rehooked it, but windows never detected it.

When rebooting the computer with the USB drive it takes around 30 seconds for the system to pass the BIOS/POST; eventually displaying an error message which displays and disappears so fast I can't read it. (If it can be paused, tell me please)

After this, Windows starts the boot up logo with the glowing icon. Then after 30 seconds of that, it disappears and the system does nothing.

1 hour of waiting, screen is still black so I unplug the USB drive and the computer boots up perfectly.
---

I've tried plugging it in while windows is running and detecting it with various software, but it never displayed at all.

BIOS/POST does detect the device as the WD 500GB External that it is; which provided peace of mind from assuming the drive is totally dead.

But aside from knowing this, there is nothing I can do to detect it after the BIOS sequence, nor access it.

Safe Mode obviously won't function since it's part of the OS, which doesn't boot up; nor does System Recovery panel.
Unplugging the device allows it to boot these without problem, but won't re-detect the drive when plugged back in.
--

My guess is a bad sector or something screwed up.
Since the drive has had some tough times where I've been doing conversion/transfer/video stuff on it and the system would crash; or the OS USB ports failed to function causing the drive to lock up (The old USB error).
It's never really been defragmented or checked for errors in the past either

Salvaging the drive is the important right now; even if the drive loses the data during that process that's what data recovery software is for.
I'd rather that be a last resort of course.

As always, help is greatly appreciated.


---
What I didn't do yet - Don't suggest these things and wait for a reply on the progress, you won't get an answer.
  • Tried another computer (I don't have another)
  • Installed drivers (It's a plug and play device, never needed drivers in the years of owning it)
  • Tried another connector (Wouldn't explain how BIOS can read from it)

Aside from the things above I've tried many technical things and good ol' methods, since I'm not a computer novice by any means.
But someone out there most likely has a wacky method to fix it up which I never would of thought of.

SilentSaber 07-16-2010 08:32 PM

Try on another operating system (any linux). Boot with verbose logging and see if any errors come up.

kag 07-17-2010 03:37 AM

If it is out of warranty open it up.
It is just a normal hard disk inside, plug it into the PC directly if it is a 3.5 (Desktop) (for 2.5 you need a converter/Laptop) and see if you have the same problem.
But you should do this until you tried changing cables and other computers.
Also you should try plugging it in the back as the USB provides more power.

It sounds more like the external device's controller is dead or the hard disk controller.
If you have some other software, check the SMART.
If your BIOS is able to disable SMART, disable it cause SMART might be "stucked" cause it is waiting for the drive to respond.

Light 07-17-2010 04:48 PM

Quote:

Originally Posted by kag (Post 1294273)
If your BIOS is able to disable SMART, disable it cause SMART might be "stucked" cause it is waiting for the drive to respond.

Perfect, the problem has been solved.
Thanks.


All times are GMT -7. The time now is 08:08 AM.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.