ggFTW (
-   Elsword (
-   -   HKElsword is out! (registration guide within!) (

Endgame 12-01-2009 12:35 PM

HKElsword is out! (registration guide within!)
(Elswordm㺸n is the site for it, but you don't need to go there. At all.)

Yes, the Hong Kong version of the game is now out, and unlike the korean and taiwanese versions of the game, there is no need for any sort of identification number! No risk of international identity theft here! However, only the original three characters are available right now. Not a problem for me, but it might be a problem for those of you who like robot arms or slapping your enemies to death.

Want to join? Here's what you need to do:

First, go here:

I've made a handy guide:

(The lowercase only part had me stumped for a bit. Thankfully, Babelfish CAN come through sometimes.)

After that, you do the normal check your e-mail and click the link thing to confirm. Upon clicking the link, you will be shown a list of games (HK Grand Chase is there too!), buttons below them, and an accept button at the bottom. I'm sure you can figure out what to do here..... (Hint: The game's title is written in english.)

Congratulations! You just made a Gamania account that can access HKElsword!

Now you need the client.

You can download it in three parts from sucky servers here:
Elsword U

Download it from a faster, but Hong Kong only server here (need a proxy to use):
Elsword U

OR download it from Megaupload here!:
MEGAUPLOAD - The leading online storage and file delivery service

NOTE: There is apparently a problem with Windows Vista and Windows 7 where the game will freeze at startup or give you a button to click on to close the window, then the .exe will become unrunnable. In order to get around this, you apparently have to disable any firewalls you have (including Windows Firewall) and run the program as Administrator. It will still take a while before it loads up the patcher though, give it some time.

No, the patcher speed is not an indication of how laggy the game will be.

And that should be it. Have fun!

Reminder: When playing on foreign versions of any MMORPG, please try to make as little a presence as you possibly can. Don't speak english in public or other such things to attract negative attention. If foreigners are deemed too much of a problem, they WILL kick us out by blocking all foreign IPs.

neodrakeflare 12-01-2009 01:36 PM

hong kong speaks english!:py12:

Noperative 12-01-2009 04:32 PM

:py01:English release now, ploz. This is good though, I could play this.

Endgame 12-02-2009 06:07 AM

Bad news, I DID manage to get the client, however, I cannot get the game to work. A window pops up, just like with the korean version (I made a "guest account", those are legal), it either freezes there, or twice, I've gotten the text to change with a button under it, but upon clicking it, the program closes, and then the program changes icon, and then tells me it's an invalid Win32 application when I try to run it.

I am however, currently uploading it onto Megaupload anyway. In case someone else wants to try to figure it out, and so I can try it out on the other computers in case it might be a Vista problem. (The CDs I have are too small to burn it on to.)

Edit: Apparently, this is a known problem. From the website:


Light of brave dear Aier: If opens time the Elsword program dodges crazily unceasingly reopens crazily. May try the following methods solution. 1. like Window the Vista/Window7 user, please use the system manager status to open the Elsword program 2. like to use first step still not to be able to solve unusually, please close the firewall or establishes the firewall to allow the Elsword safe connection to try again. Aier light of brave Lei Liuzi

I'm going to try running as administrator (although I AM the administrator) and/or disabling Windows Firewall as soon as it's done uploading and see if it works.

Edit: Yes! I got it to start patching! However, I still had to wait a while, where it seemed like it was frozen before the patcher started up.

Another edit: Everything's working fine now.

Some things of note:

-Despite the slow download speeds, the game does NOT lag badly. Slight lag in picking up items, but that's it. Haven't tried playing with any locals yet though.
-There's only two character slots. (It's probably for the best. Now I won't be tempted to make an Elsword named "Elebro". Yes, I'm a horrible person.)
-Despite only having the first three characters and no job advancements, the HK version already has recent features such as the towns, four skill keys, and the new SP distribution system.

Noperative 12-06-2009 05:49 PM

So who's playing HKElsword? I started a Rena named Midori but I haven't actually played Elsword before that and don't know what to do.

Rionell 12-08-2009 07:28 PM

I'm going to try it. The patcher won't start up for me, though. I'm too lazy to see what could be the problem, so I'll deal with it later.

Side note, I'm using Vista atm. I normally use XP but right now my laptop's unavailable, so until I get mine back I'm stuck with this current laptop. I'll see what I can do about the patcher sooner or later.

Kuroowns 12-09-2009 06:44 PM

Hm, Korean Elsword lags a bit for me, so I'm going to try HKElsword to test the lag. If it goes well, I'll probably stay there since Hong Kong, as mentioned before, does have many English speakers.

Askarion83 12-10-2009 06:51 AM

I am using XP atm and i have disabled the Firewalls and virus Programms and i have still the same problem ! i can do what i want the patcher dont start it always frezzing at the first screen ! Anyone know now how to fix it ?


Rionell 12-10-2009 03:18 PM

^ They said you'd have to wait a while... Also, did you run it as an administrator? Otherwise, I have no idea. I've yet to experiment on how to make it work for me, too.

Endgame 12-11-2009 08:12 PM

I have no idea what to tell you if you're having the problem in XP.

However, I have found that other people have had a problem installing in XP. If you're getting some kind of syntax error, then try this:

Go to Control Panel -> Regional and Language Options. Click on the Advanced tab, then select "Chinese (Hong Kong)" for language for non-unicode programs.

HolyAbyssal 12-12-2009 06:33 AM

I'm trying it :3

Sorry for the double post, but Is the error supposed to look like the image in the picture : V

Because I can't translate for shiz

l666lFaze 12-13-2009 10:25 AM

I got it working All if u get that Errror when u start the launcher just use proxifier or any other proxy Program and get a HK proxy thats what i did to get passed error and while patching u should use a HK proxy since for me when i didnt it would download the file then at 20 percent would start all over and when i had the proxy on it went all the way to 100 percent lol

Firagagun 12-13-2009 11:05 AM


Originally Posted by HolyAbyssal (Post 1090115)
I'm trying it :3

Sorry for the double post, but Is the error supposed to look like the image in the picture : V

Because I can't translate for shiz

Nope it's loading, wait for a while and it'll go to patcher.
First time it happened to me I thought it wasn't working lol, just leave it there and it'll work.

HolyAbyssal 12-13-2009 11:16 AM

I hope it doesn't take like 1hour to load :<


mopdog 12-22-2009 05:31 PM

Im still having issues even with all firewalls off. That dreaded win32.dll error! =[

elkasan 12-22-2009 11:25 PM

Hi um
I downloaded the MEGAUPLOAD file and i installed it but how exactly do i run elsword?
I didnt get an icon on my desktop.

CodeCynthetik 01-26-2010 06:55 AM

I got the same chinese error message problem.

I was just informed that you need a Hong Kong IP address, or bypass it with a proxy, in which I'm trying to google at the moment.

Mufalmar 01-29-2010 06:48 PM

I don't even use vista or windows 7, i use windows xp, and i'm still getting the error. No firewalls, my antivirus is off, and i don't know what to do..

sumon 01-31-2010 05:48 AM

If Anyone knows, help us to Bypass the HK IP or something.. Thanks in Advance

Leilo 01-31-2010 08:58 PM


Originally Posted by Firagagun (Post 1091568)
Nope it's loading, wait for a while and it'll go to patcher.
First time it happened to me I thought it wasn't working lol, just leave it there and it'll work.

about how long does this take?

All times are GMT -7. The time now is 01:46 PM.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.