ggFTW

ggFTW (http://ggftw.com/forum/)
-   Dungeon Fighter Technical Issues (http://ggftw.com/forum/dungeon-fighter-technical-issues/)
-   -   Game Crashes Before Launch (http://ggftw.com/forum/dungeon-fighter-technical-issues/86647-game-crashes-before-launch.html)

Inexosino 11-24-2010 07:50 PM

Game Crashes Before Launch
 
I'll start with my computer's specs; I'm not a genius at computers, so I'm not sure if what I can provide is enough, but here goes.

Operating System: Windows 2000 Professional
Graphics Card: Intel Extreme 3-D Graphics
Browsers: Firefox 3.6
Regional Options: English (US)

This issue started about a year or so ago, after Act I and the whole website revamp. Before, DFO worked perfectly fine, as it had for about two months before the whole onslaught of updates. But right after was when things started getting messy.

The basic gist of it was this: I would double-click the DFO icon on my desktop, and the site would open up in IE 6. Thanks to the Act I site upgrades, IE 6 had numerous errors on the page (for example, the username and password fields wouldn't show up), and when I logged in regardless and started the game, the DFO Launcher would pop out. It'd install whatever updates there were to install, close down, and then - nothing would happen. When I opened up task manager, it would show that DFO.exe would launch for about 2 seconds, and then immediately exit right after. No error messages or warnings or anything of the sort. At that time I've tried everything that was obvious to try: Restart computer, check Internet connection (which was fine), uninstall, reinstall, send tickets (none of the replies sent back were helpful) and post a couple threads on the Nexon forums. At that point I quit since DFO wouldn't work.

Now, it's been a year later, and two days ago I figured that I'd try reinstalling again and launching DFO via the DFOLauncher in the Nexon folder (which, as it happened, didn't work since it was the "Neople launcher"). After that I opened up Firefox (which never had any page errors), logged into the DFO website, and tried launching the game there. Interestingly, it worked - but only for two days. Now I'm back at the same situation I was a year ago, and I'm currently waiting for DFO to reinstall (again) to see if that would help with anything.

Does anyone have any solutions or suggestions? I remember reading a thread on GameSpot forums that mentioned setting the language for all non-unicode programs to English, but I have no idea how to do that.

GameSpot Forums - Dungeon Fighter Online - Anyone ever get this problem before? (Or I got a starter problem topic.)

Nihil679 11-24-2010 08:18 PM

If you go into something along the lines of Control Panel -> Clock, Language, Region -> Region and Language (box pops up) -> Administrative -> Language for non-Unicode Program box, it should display something like English (United States) or so. That means you are on an English locale. If it says otherwise, like mine says Japanese (Japan) (which is why I can't play DFO, lazy to change), you won't be able to play.

You can try using DFOCP (DFO Control Panel) if you believe it's a browser problem. I know that I, myself, can't run DFO from Firefox (it keeps prompting me to redownload it) and I just don't like opening Internet Explorer.

[Release] DFO Control Panel - Dungeon Fighter Online forum

It's fan-made, but many people use it. All you really need is to download it, run it and hope it picks up DFO, then enter in as you normally do and see if it works.

Other factors that may be a problem is, when you start up the game, you get the black box, correct? If you click it, it will close. Your best bet is to open up another window after it minimizes everything and wait to see if the game closes or not.

Inexosino 11-24-2010 08:38 PM

I didn't find the "Clock" option on my control panel. Just date and time, which didn't have any regional options.

:hmm:

I've heard of the DFO CP, but I haven't tried it yet. Thanks for the suggestion, I'll download it once DFO finished updating to Act V a second time.

And actually, I don't get the black box. (Though I did when DFO worked for those two days; I just left it alone and it'd enter full screen after a little bit.) The DFO updater launches, uploads any available patch files, then closes, and nothing else pops up after that; no warnings or anything and especially not DFO proper. I've checked Event Viewer if there were any error messages that didn't openly show, but so far I haven't found anything.

RoflKnife 11-24-2010 08:44 PM

Also, after a recent maintenance, a good deal of people are experiencing problems launching the game (including me), so wait a day or two for a fix.

Fuzzy 11-25-2010 07:02 PM

I've been trying since the Skill reset to fix my DFO.

I get the black box... then the black box goes full screen and my monitor says "disconnected" and goes into sleep mode... No fix found for me yet either... so if you happen to solve the problem do share with me

RoflKnife 11-26-2010 11:55 PM

Fixed mine.

Windows 7 64-bit
Disabled both the Launcher.exe and DFO.exe compatibility mode, and turned on "Disable Desktop Composition" for both the files.

Inexosino 11-27-2010 11:52 AM

Quote:

Originally Posted by RoflKnife (Post 1409621)
Fixed mine.

Windows 7 64-bit
Disabled both the Launcher.exe and DFO.exe compatibility mode, and turned on "Disable Desktop Composition" for both the files.

Uh...will that work for my computer? Because mine is a Windows 2000.

RoflKnife 11-27-2010 12:47 PM

I don't think so. You can try fiddling with the compatibility settings, but before that try changing your unicode to english if you haven't already. Don't know about 2000, but it should roughly be:

Control Panel -> Languages~ -> Look for unicode/locale~ -> change it to English (US)


All times are GMT -7. The time now is 06:21 AM.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.